1965 intermittent indicator issue

Mustang Australia

Author Topic: 1965 intermittent indicator issue  (Read 679 times)

Offline Bitty65

  • Pony
  • **
  • Posts: 36
  • Welcome to the Mustang Forum
1965 intermittent indicator issue
« on: September 24, 2019, 08:02:46 PM »
Hoping someone can help with an issue i'm having with indicators on my 65.
On left turns, everything works fine.
On right turns, sometimes everything works fine, however sometimes the dash light and front indicator does not flash whereas the rear indicator keeps flashing normally.
Fiddling with the wires under the dash sometimes temporarily fixes the issue, but for the life of me, I can't see anything obvious.
Being an intermittent issue, it's somewhat frustrating to pinpoint therefore if anyone has any ideas on what the issue might be, I'd love to hear from you.

Offline unilec5544

  • Worked
  • ***
  • Posts: 892
  • Location: Perth WA.
  • Name: Neil.
Re: 1965 intermittent indicator issue
« Reply #1 on: September 25, 2019, 12:13:50 PM »
Because the early Mustangs had a system where the rear globe did park,stop and indicator, the indicator switch has two separate sets of contacts for the turn signal, so that may be your fault. It can also be a bad earth, a loose connection as well. Do you have a multi meter?

Offline Bitty65

  • Pony
  • **
  • Posts: 36
  • Welcome to the Mustang Forum
Re: 1965 intermittent indicator issue
« Reply #2 on: September 25, 2019, 09:05:22 PM »
I do have a multi meter Neil.
FYI, the rear indicators are separate from the brake lights.

Offline unilec5544

  • Worked
  • ***
  • Posts: 892
  • Location: Perth WA.
  • Name: Neil.
Re: 1965 intermittent indicator issue
« Reply #3 on: September 25, 2019, 09:25:33 PM »
OK, so if you look under the dash at the bottom of the column there is a 6 pin plug  and a 2 pin plug, disconnect the 2 pin plug and with your meter on dc volts you should have 12v on the orange /blue wire that feeds the right side indicator when you place the indicator in right indicator position, so do this first and check the left side as well.
« Last Edit: September 25, 2019, 09:27:12 PM by unilec5544 »

Offline Bitty65

  • Pony
  • **
  • Posts: 36
  • Welcome to the Mustang Forum
Re: 1965 intermittent indicator issue
« Reply #4 on: September 28, 2019, 12:03:27 PM »
Thanks Neil.
I found a dodgy connection in the 6 pin plug. It looked as though one of the pins was pushed out when the connector went together.
It's all working fine now, so hopefully stays that way.

Offline unilec5544

  • Worked
  • ***
  • Posts: 892
  • Location: Perth WA.
  • Name: Neil.
Re: 1965 intermittent indicator issue
« Reply #5 on: September 28, 2019, 12:10:13 PM »
Awesome, it a good feeling when you can fix issues on these old cars. :thumb:

 

Visit Custom Mustangs

Visit Custom Mustangs