Author Topic: front indicator/park globes  (Read 588 times)

0 Members and 1 Guest are viewing this topic.

Offline butts67

  • Pony
  • **
  • Posts: 44
  • waiting for summer
  • Location: south gippsland
front indicator/park globes
« on: July 14, 2018, 01:24:21 PM »
hi all
I am replacing the front indicator globes on my 67
had to break the old globes and remove the base with pliers.
I have freed the spring holder with wd40
trying to put the new globes in but cant get enough grip on bulb to lock them in
is there a special tool or trick to get them to lock in
I have the offset pins in the correct position

cheers

Offline GLENN 70

  • GT 500
  • *********
  • Posts: 8177
  • Location: Gold Coast .
Re: front indicator/park globes
« Reply #1 on: July 14, 2018, 02:20:17 PM »
Nope no tricks , put on cloves in case the glass breaks .

Offline BAC

  • Blue Printed
  • ****
  • Posts: 1720
  • Location: Melbourne
  • Name: Brian
  • Car: '68 J Code GT 4 speed
Re: front indicator/park globes
« Reply #2 on: July 14, 2018, 05:15:29 PM »
Maybe give the inside of the bulb socket a light sand to smooth it out a little.
Cheers,
Brian

Offline butts67

  • Pony
  • **
  • Posts: 44
  • waiting for summer
  • Location: south gippsland
Re: front indicator/park globes
« Reply #3 on: July 15, 2018, 10:42:35 AM »
after another half a can of wd40 some extra manipulation of spring contacts and one rubber glove
I have finally got them in
thanks for the advise

cheers

Offline Paul Clark

  • Thoroughbred
  • **
  • Posts: 145
Re: front indicator/park globes
« Reply #4 on: July 16, 2018, 04:30:35 PM »
Nothing like perseverance.

Offline BAC

  • Blue Printed
  • ****
  • Posts: 1720
  • Location: Melbourne
  • Name: Brian
  • Car: '68 J Code GT 4 speed
Re: front indicator/park globes
« Reply #5 on: July 16, 2018, 04:50:12 PM »
after another half a can of wd40 some extra manipulation of spring contacts and one rubber glove
I have finally got them in

 :thumb:
Cheers,
Brian

Offline barnett468

  • Shelby
  • *********
  • Posts: 6414
Re: front indicator/park globes
« Reply #6 on: July 17, 2018, 01:58:40 AM »
ummm...you can file the lead contacts down on the bulb a little, and if that doesn't work, pull hard on the wires to retract the contact plate then install the bulbs while pulling the wires.


Offline IGALOP

  • Pegasus
  • *******
  • Posts: 4603
  • I have "CRAFT" Can't remember any F'n thing.
  • Location: Gippsland , VIC
  • Car: 67 Coupe, 289 C-code.
Re: front indicator/park globes
« Reply #7 on: July 19, 2018, 04:27:36 PM »
Go to a Clarks Rubber store or Bunnings and get some clear plastic tubing that fits snuggly almost tightly around the globe ......Push it in to socket and turn to lock globe into place. Carefully pull tube from locked in globe. A bit fiddly but that's how I did mine. :thumb:
Johnno;
 
Proud Vic MOCA member # 1569

I know it seems like I am in denial.........but I am absolutely not !!

 

Visit Custom Mustangs